Saltar al contenido

Configurar sdk android studio

Android studio sdk manager

Ya sea que est茅 construyendo una aplicaci贸n de Android en Unity o program谩ndola desde cero, necesita configurar el SDK de Android (kit de desarrollo de software) antes de poder construir y ejecutar cualquier c贸digo en su dispositivo Android.

Siga las instrucciones en Instalaci贸n del SDK. Puede omitir las secciones opcionales relacionadas con Eclipse. En el paso 4 de la Instalaci贸n del SDK, aseg煤rese de a帽adir al menos una plataforma Android con un nivel de API igual o superior a 9 (plataforma 2.3 o superior), las herramientas de plataforma y los controladores USB si utiliza Windows.

Para habilitar la depuraci贸n USB, primero tienes que activar las opciones de desarrollador. Para ello, navega por tu tel茅fono hasta la parte 芦N煤mero de compilaci贸n禄 en los Ajustes de tu dispositivo. Encontrarlo puede ser diferente dependiendo del dispositivo:

Navega hasta el n煤mero de compilaci贸n siguiendo las instrucciones anteriores. Pulse 7 veces sobre el n煤mero de compilaci贸n. Aparecer谩 una peque帽a notificaci贸n emergente que dice 芦ahora est谩s a X pasos de ser un desarrollador禄 con un n煤mero que se reduce con cada toque adicional. Al s茅ptimo toque, se desbloquean las opciones de desarrollador. Ve a Ajustes > Opciones de desarrollador y marca la casilla de depuraci贸n USB para activar el modo de depuraci贸n cuando el dispositivo est茅 conectado a un ordenador por USB.

Descarga del sdk de Android 11

Unreal Engine 4.25 y posteriores utilizan el kit de desarrollo de software de Android (SDK) distribuido con Android Studio para todos los componentes esenciales de desarrollo de Android, incluido el kit de desarrollo nativo de Android (NDK). En esta p谩gina se ofrece una gu铆a para configurar Android Studio y asegurarse de que Unreal Engine reconozca estos componentes correctamente, as铆 como algunos consejos para solucionar problemas relacionados con la gesti贸n de las instalaciones del NDK y las compilaciones anteriores del motor.

Debes asegurarte de que el Editor de Unreal y el Epic Games Launcher est谩n cerrados para garantizar que no hay problemas con la instalaci贸n de los componentes del NDK o con la configuraci贸n de las variables de entorno para el motor.

Si est谩s actualizando desde Unreal 4.24 o anterior, te recomendamos que desinstales CodeWorks para Android y cualquier componente NDK existente, y que elimines la carpeta en la que se instal贸 CodeWorks. De lo contrario, Android Studio seguir谩 utilizando la carpeta de instalaci贸n anterior de CodeWorks para las actualizaciones del SDK.

Si necesitas dar soporte a una instalaci贸n anterior de Unreal Engine a la vez que mantienes una instalaci贸n de Unreal 4.25 o posterior, consulta las secciones sobre Rutas del SDK de destino manual y Compatibilidad con el NDK de Android que aparecen a continuaci贸n.

Proguard

Este cap铆tulo proporciona informaci贸n sobre la instalaci贸n y configuraci贸n de las herramientas de desarrollo para la plataforma Android. Instale el SDK de Android y el acelerador del emulador para poder desplegar las aplicaciones MAF desarrolladas en JDeveloper en un dispositivo o emulador Android configurado.

Instale Android Studio, y el SDK de Android que incluye, descargando el archivo de instalaci贸n de https://developer.android.com/studio/index.html. El sitio web de Android Developer proporciona instrucciones de instalaci贸n para Windows, Mac y Linux. Consulte https://developer.android.com/studio/install.html.

Una vez instalado, el acelerador del emulador acelera el rendimiento del emulador y de los AVD que emula asignando recursos adicionales de su m谩quina de desarrollo. La cantidad se especifica durante la instalaci贸n del acelerador. Una vez instalado, el acelerador aparece en la lista de herramientas del SDK del SDK Manager que puedes lanzar desde Android Studio, como se muestra en la siguiente imagen. El acelerador de emuladores Intel x86 (HAXM) es un tipo de acelerador de emuladores que est谩 disponible.

Eclipse

Algunos de vosotros os enfrent谩is constantemente a este problema, y esta 芦soluci贸n禄 lo arregla s贸lo temporalmente. En el momento en que empezamos a tener este error, usamos el gradle wrapper 4.6 y el plugin de gradle para Android 3.1.0, pero desde entonces volvimos a gradle 4.4 y lo usamos con el 煤ltimo plugin de gradle para Android, y no hemos visto este problema desde entonces.

Presionamos 禄 鈱 + Shift + A禄 en Mac (o 芦Ctrl+Shift+A禄 en Windows) y en el EditText emergente, escribimos 芦Sync Project with Gradle Files禄. Despu茅s de eso, haz doble clic en la opci贸n aparecida. Entonces se sincronizar谩 tu SDK de archivos Gradle con el archivo del proyecto.

En mi caso descargu茅 un repositorio git para un proyecto android. El proyecto requer铆a como m铆nimo la versi贸n 21 del sdk y la versi贸n 27 del target sdk. Cuando intent茅 ejecutar el proyecto me dio 芦Error de selecci贸n del SDK de Android禄. Comprob茅 que ya hab铆a descargado los archivos sdk necesarios.

0/5 (0 Reviews)